Fin 2018, c'est le moment de mettre à jour !

C'est le 1er décembre que le support de la version 7 LTS de TYPO3 se termine. Une autre fin, c'est celle aussi de la version 5.6 de PHP.

Après 21 mois de bons et loyaux services, TYPO3 7 LTS tire sa révérance. Ainsi, si votre site internet fonctionne toujours sur cette version, vous ne serez plus protégé des failles de sécurité et vous ne recevrez plus aucune mis à jour. Vous n'aurez d'autre choix, que de passer à la version 8 ou bien à la version 9 qui est sortie il y a peu de temps. Il ne s'agit pas non plus de mettre à jour le coeur applicatif. En effet, PHP 5 est en "EOL" ou "End of life". Beaucoup de serveurs malheureusement tournent encore sur cette version. PHP 5.6 a été lancé le 28 août 2014 et la fin de son support se termine le 31 décembre 2018. Passez donc à PHP 7 le plus vite possible si ce n'est pas encore fait, les versions 7.1 ou 7.2 sont recommandées. TYPO3 version 8 LTS est compatible avec PHP 7.1 et PHP 7.2. La version 9 LTS vous offre davantage de sérénité car son support est prévu jusqu'en 2024 et elle est compatible avec PHP7.3 (voir la roadmap de TYPO3).

Vous avez été mis en garde ! Sachez que LucidLab peut s'occuper de la mise à jour de votre serveur et de TYPO3 le cas échéant ;-)